27 Apr 2016

Dear community, we just published Kamon 0.6.1 which has a few minor bug fixes and a correctly published kamon-akka-remote module for Akka 2.4.

Thanks to João Ferreira we now have a new Elasticsearch module! We are looking forward to your feedback with regards to this module, take a look at the related docs and give it a try.

For people using Akka 2.4, you can now safely use kamon-akka-remote_akka-2.4 without having workaround the wrong dependencies that were published with Kamon 0.6.0 (sorry about that :/).

Thanks a lot to everyone who provided feedback, fixes and even new modules, we really appreciate your enthusiasm! Without anything else to say, here is the changelog extract for this release:

  • kamon-core:
    • Add tags for Traces. (see issue #327).
    • Catch any exception being thrown when recording values on histograms. see pull #335).
  • kamon-akka-remote
    • Correctly published kamon-akka-remote_akka-2.4 for people using Akka 2.4.
  • kamon-newrelic:
    • Update newrelic-agent dependency. (see pull #330).
  • kamon-statsd:
    • in “normalize” strategy - add replace(“:”, “-“) after replace(“: “, “-“) to cover the remotely deployed actors case. (see pull #325).
  • kamon-elasticsearch:
    • We have a new Elasticsearch integration! (see pull #309).
  • kamon-autoweave:
    • Remove usage of breakable. (see pull #338).
  • kamon-spray:
    • Add tags in spray spray directives for tracing. (see issue #345).

As always, have fun with Kamon!



comments powered by Disqus